2021-02-22に更新

FlutterのAndroidで最新のFirebase Analytics入れるとエラーになる件について

FlutterにてAndroidで開発をしていた時に、最新のFirebase Analyticsであるfirebase_analytics 7.0.1 を利用するとなんかビルド時にこんなエラーが出る。全くよくわからない。

FAILURE: Build failed with an exception.

* What went wrong:
Could not determine the dependencies of task ':app:compileDebugJavaWithJavac'.
> Could not resolve all dependencies for configuration ':app:debugRuntimeClasspath'.
   > Problems reading data from Binary store in C:\Users\user\AppData\Local\Temp\gradle1639466432759139497.bin offset 194769 exists? true

このとおりにしたら直った。
https://github.com/gradle/gradle/issues/8489#issuecomment-774436851

具体的にはbuild.gradleで指定しているパッケージのバージョンを上げる。

app配下の build.gradle

com.google.firebase:firebase-analytics:18.0.2

プロジェクト配下の build.gradle

com.google.gms:google-services:4.3.5
ツイッターでシェア
みんなに共有、忘れないようにメモ

だら@Crieit開発者

Crieitの開発者です。 Webエンジニアです(在宅)。大体10年ちょい。 記事でわかりにくいところがあればDMで質問していただくか、案件発注してください。 業務依頼、同業種の方からのコンタクトなどお気軽にご連絡ください。 業務経験有:PHP, MySQL, Laravel, Vue.js, React, Node, RoR 趣味:Elixir, Phoenix, Nuxt, Express, GCP, AWS等色々 PHPフレームワークちいたんの作者

Crieitは誰でも投稿できるサービスです。 是非記事の投稿をお願いします。どんな軽い内容でも投稿できます。

また、「こんな記事が読みたいけど見つからない!」という方は是非記事投稿リクエストボードへ!

有料記事を販売できるようになりました!

こじんまりと作業ログやメモ、進捗を書き残しておきたい方はボード機能をご利用ください。
ボードとは?

コメント