2019-06-19に更新

【禅Do】Swift2.3のアプリをSwift5対応にしたい

大枠

数年前にSwiftの勉強のために作ったiOSアプリを、リリース後に全く
アップデート対応していなかったので気がついたらSwiftのバージョンも5になってた。

このアプリのWeb版出したりとか諸々やりたいことが出来てきているので
とりあえず最新版のSwiftに対応して一度アプリを
更新リリースするところまでやることにした(頑張る)

前提条件

  • 1,2年ほどiOSアプリ周りを全く触ってなく以下は忘却されている
    • Swiftの文法、機能について
    • Xcodeでの各種設定について
    • リリースまでに必要なりソース、手順について
    • 導入したOSSライブラリについて
  • アプリ自体の機能はかなり控えめなので、コード量自体は多くない
  • 当時リアクティブプログラミングの勉強を兼ねてBondというライブラリを利用している
    • RxSwiftとかを入れるほど大した機能はなかったので、機能が控えめなBondを入れた経緯
    • ただ当時から大分実装が変わっているようなので、コレの置き換えが一番手間かかりそう

view_list Swift2.3で作った個人開発アプリをSwift5対応にする
第1回 【禅Do】Swift2.3のアプリをSwift5対応にしたい
第2回 【禅Do】利用しているライブラリについて

stlwolf

Crieitは個人で開発中です。 興味がある方は是非記事の投稿をお願いします! どんな軽い内容でも嬉しいです。
なぜCrieitを作ろうと思ったか

また、「こんな記事が読みたいけど見つからない!」という方は是非記事投稿リクエストボードへ!

こじんまりと作業ログやメモ、進捗を書き残しておきたい方はボード機能をご利用ください!

ボードとは?

関連記事

コメント